Diesel bike – Injector line heater

As most of you know, I run my Xj600 diesel bike purely on WVO (Waste Veg oil). I mix it with 5% Petrol, but during the winter its still very hard to start. This is mainly down to the thickness of the vegetable oil at low temperatures.

To counteract this, I have installed an injector line heater. I used Kapton tape and nichrome heating wire. Kapton tape  a thermal limit of about 250 degrees C and is very thin so aids heat transfer better. I wrapped 2 sections of nichrome wire after wrapping the injector line in kapton tape. Each coil draws around 4 amps.

The temperature aim is around 75 degrees c, to measure how long I would have to run the coils for, I crimped one end of a copper pipe and wrapped it with kapton tape, then the heating coils. I filled it with WVO and inserted a temperature probe. It took approximately 1 minute and 50 seconds to reach 80 degrees C.

As a result, I have coupled the heating elements with a 12v timer circuit and a relay. The timer is set for aproximately 1 minute 45 seconds. The output of the relay also triggers the oil pressure light on the dashboard so I can see when the coils are energised, when the light goes out I can start the engine.

With pre-heating, the engine now starts within 3 cranks rather than 10-15 as before. Even at 0 degrees c.

Some pictures below:

IMG_20140321_173542 IMG_20140321_173538 IMG_20140321_173518

443 total views, no views today

XJ 600 Diesel bike – L100 injector cleaner

Recent issues with a dodgy fuel pump on my L100 engined Diesel bike has been causing problems!

 

I had some sediment go past my primary fuel filter and get stuck in my injector which was a pain!
A new injection pump was fitted and some injector cleaner ran through the system but I still had issues, mainly really bad diesel knock and very hard starting.

I initially suspected a blocked/faulty fuel injector, considering it has had WVO running through it, so I pulled it from the engine.

This is what it looked like before cleaning:

IMG_20131109_134342 IMG_20131109_134348

 

A quick trip in the ultrasonic bath:

IMG_20131109_135133

 

and after:

IMG_20131109_141109 IMG_20131109_141117

 

Turns out, that didnt help at all! It was the injection pump causing the problem, as a second replacement injection pump sorted the problem! Happy days.

478 total views, no views today

XJ 600 Diesel bike – Water injection

Right, so part of the quest to keep the bike running well, I have fitted a water injection system to ensure that ring gumming is kept to a minimum.

This system is very simple and is made entirely from a very cheap 1.2L windscreen washer kit (this one to be specific: http://www.ebay.co.uk/itm/111091290718?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2648)

First step was to modify one of the washer jets so that it produced a mist rather than a stream. This was carried out using a old soldering iron tip, and melting the the front face of the jet so that it was completely blocked, then using a very small heated nail to make a very small pin hole. Its hard to see in the picture:
IMG_20130904_115507

IMG_20130904_115500

 

The next step was to insert the jet into the intake. I had created an intake extension out of plastic for my K+N air filter, so this bit was quite easy as its plastic.

I cut out the shape for the jet and inserted into the hole, it was then glued in place from the outside (so to ensure no glue would be sucked into the engine if it fell off). Its at an odd angle as the jet does not exit in a straight line from the jet.

IMG_20130904_115448 IMG_20130904_115454 IMG_20130904_115549 IMG_20130904_120444

 

The remainder is easy, fit the tank, run the wiring and check the flow rate.

IMG_20130904_141945 IMG_20130904_141941 IMG_20130904_141953

 

Getting the flow right was the most difficult. I ended up using a hairpin shaped peice of metal over the delivery pipe, and held the revs at 3500rpm. I then ran the pump and kept compressing the clip over the pipe until the engine stopped bogging down. I confirmed that water was still flowing by looking through the intake. Happy days!

I will run 1.2 liters through the engine on each tank full, I will also be keeping a close eye on engine oil for signs of polymerisation.

873 total views, no views today